Les versions 3.15 et 3.2.0beta3 présenteraient des trous de sécurité dans le module htsearch.

L'annonce officielle
Tous les détails du problème
Les versions 3.2.0b4 et 3.1.6 qui fixent ce problème